[entities] section | Uniface 9 | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

—  Results per page  —








— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters
For a group of consecutive words like 'end of support' use Match phrase

sp_Feed Topic RSS sp_TopicIcon
[entities] section
12 Apr 2018
12:20 pm
Avatar
Jode
Member
Forum Posts: 3
Member Since:
24 Jan 2013
sp_UserOfflineSmall Offline

Hi,

I would like to define specific properties for my entities.

Is the “[entities] section”  working in the usys.ini file or it is work only with with an ini file specified with /ini

Thank you

 

Jonathan Degoumois

12 Apr 2018
12:32 pm
Avatar
diseli
Admin
Forum Posts: 967
Member Since:
01 Oct 2012
sp_UserOfflineSmall Offline

Hello Jonathan,

Welcome to the forum.

The [entities] section is defined in the assignment (ASN) file and not the INI. For details see (e.g.) the chapter “Assignment File Sections” and related sub-chapters (and related information) in the documentation.

 Hope this helps.

Kind regards,

Daniel Iseli
Uniface Support

12 Apr 2018
1:27 pm
Avatar
Jode
Member
Forum Posts: 3
Member Since:
24 Jan 2013
sp_UserOfflineSmall Offline

I talk about this [entities] used to set widget properties for the default entity

to use udefentity 

[entities]

entstyle_0=udefentity(bordertype=flat)
entstyle_1.dummy=udefentity(backimage=@..\images\sky.png;valign=center;halign=center)
person.org.FRM_CONTACT=udefentity(bordertype=flat;backcolor=blue;borderradius=20px)

 

thank you

13 Apr 2018
1:09 pm
Avatar
diseli
Admin
Forum Posts: 967
Member Since:
01 Oct 2012
sp_UserOfflineSmall Offline

Thanks for clarifying this.

I did a quick check in it seems that Uniface will read the udefentity settings only from the specified INI-file. So in case you are using an application-specific INI (specified with /ini) then the settings in the usys.ini (in the USYSADM-directory) are ignored, even when the application-specific INI does not have an [entities] section. This is at least what I can see here. I’m currently not sure if this behavior is intended.

So in case you are using /ini then you have to make sure that the required udefentity-definitions are in the application-specific INI-file.

Hope this helps.

Daniel

17 Apr 2018
12:06 pm
Avatar
Arjen van Vliet
Member
Forum Posts: 175
Member Since:
01 Oct 2012
sp_UserOfflineSmall Offline

About 10 minutes into this video, I cover some of the entity properties that can be set through the ini file

23 Apr 2018
8:49 am
Avatar
diseli
Admin
Forum Posts: 967
Member Since:
01 Oct 2012
sp_UserOfflineSmall Offline

Jode said
Is the “[entities] section”  working in the usys.ini file or it is work only with with an ini file specified with /ini

I had another look at this and it seems that this problem already has been recognized as Issue 31136 (UF97: [areaframes] & [entities] not read from default INI when using local INI). At this moment this matter is still unresolved.

Hope this helps.

Daniel

23 Apr 2018
1:24 pm
Avatar
Jode
Member
Forum Posts: 3
Member Since:
24 Jan 2013
sp_UserOfflineSmall Offline

Thank you Diseli.

Is exactely the issue 31136.

 

Jonathan

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 131

Currently Online: Iain Sharp, tommyb42
26 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

ulrich-merkel: 1788

Iain Sharp: 654

Theo Neeskens: 357

gianni: 312

rogerw: 261

istiller: 252

Knut: 214

lalitpct: 197

Arjen van Vliet: 175

sochaz: 173

Member Stats:

Guest Posters: 3

Members: 8917

Moderators: 0

Admins: 8

Forum Stats:

Groups: 1

Forums: 62

Topics: 2206

Posts: 9539

Newest Members:

EddieUrict, Waltershago, Phyllisvar, Calvindax, RobinMarttensss, rickqo3, Henryexham, MichaelSew, EROnedieby, christinalf3

Administrators: admin: 23, Adrian Gosbell: 318, diseli: 967, Bob Maier: 3, Nico Peereboom: 77, Michael Rabone: 4, richiet: 406, JanCees: 29