Mobile App SSL Cordova.js Issue | Bugs, Issues and Errors | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

—  Results per page  —








— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters
For a group of consecutive words like 'end of support' use Match phrase

sp_Feed Topic RSS sp_TopicIcon
Mobile App SSL Cordova.js Issue
21 Sep 2017
8:22 pm
Avatar
johangel
Member
Forum Posts: 4
Member Since:
21 Sep 2017
sp_UserOfflineSmall Offline

Hi, i’m developing a mobile app in uniface on a server with SSL configuration for tomcat, the problem arises when the user call a method or plugin of cordova in the app, it show an error of mixed content like this http://prntscr.com/go0wsc 

I want to know if anyone have this same problem or where is the cordova.js file to place it manually in the set state trigger

Or, is any way to configurate the tomcat service to allow this kind of content?

22 Sep 2017
8:42 am
Avatar
diseli
Admin
Forum Posts: 840
Member Since:
01 Oct 2012
sp_UserOfflineSmall Offline

Hello and welcome to the Uniface.info forum.

The problem you are describing already has been recognized as BUG#31517 (Mobile apps: The HTTPS version does not work when calling Cordova objects) and the lab is currently working on a fix. If everything goes according to plan then this should be resolved in one of the next patches. I’ll provide another update here as soon as I know more.

In the meantime you could have a look at the workaround for BUG#31517.

Hope this helps.

Kind regards,

Daniel Iseli
Uniface Technical Support

22 Sep 2017
4:22 pm
Avatar
johangel
Member
Forum Posts: 4
Member Since:
21 Sep 2017
sp_UserOfflineSmall Offline

Hi, thaks for your answer, i already have a workaround for this.

In the tomcat 8 server.xml file add a connector to a new port that only accept http request, and in the web.xml file comment the line of “<transport-guarantee>”. This allows me to call that services without the error.

Thanks.

22 Sep 2017
4:44 pm
Avatar
diseli
Admin
Forum Posts: 840
Member Since:
01 Oct 2012
sp_UserOfflineSmall Offline

Hi,

Thanks for your reply. And you are welcome. It’s good to hear that you could find another workaround for this problem.

Daniel

29 Sep 2017
5:39 pm
Avatar
diseli
Admin
Forum Posts: 840
Member Since:
01 Oct 2012
sp_UserOfflineSmall Offline

Hi,

Just a quick update: if everything goes according to plan then BUG#31517 will be fixed with the next patch (G403) that is scheduled for next week. It is possible that in case some problems are encountered during testing that the fix has to be postponed the following patch (G404) that is scheduled two weeks later.

Hope this helps.

Daniel

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 131

Currently Online: Robertadus, jgilbert
17 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

ulrich-merkel: 1713

Iain Sharp: 623

Theo Neeskens: 345

gianni: 265

rogerw: 232

istiller: 201

lalitpct: 197

Knut: 179

Arjen van Vliet: 172

-GHAN-: 171

Member Stats:

Guest Posters: 3

Members: 7058

Moderators: 0

Admins: 8

Forum Stats:

Groups: 1

Forums: 62

Topics: 2062

Posts: 8874

Newest Members:

jgilbert, Burihelmquife, noayiruxuwu, JamesExews, Josephdurse, utemajek, ejxipayu, egekigoyik, upkuvuc, iraqojiyp

Administrators: admin: 23, Adrian Gosbell: 286, diseli: 840, Bob Maier: 3, Nico Peereboom: 65, Michael Rabone: 4, richiet: 406, JanCees: 28