Uniface 9.7.02 Patch G201 Issues | Bugs, Issues and Errors | Forum

Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

—  Results per page  —








— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters
For a group of consecutive words like 'end of support' use Match phrase

sp_Feed Topic RSS sp_TopicIcon
Uniface 9.7.02 Patch G201 Issues
23 Jun 2016
9:51 am
Avatar
Daniel_Kurz
Member
Forum Posts: 16
Member Since:
26 Jul 2013
sp_UserOfflineSmall Offline

Hi all,

we were looking forward to install Patch G201 because of 2 reasons:

– Having the Editboxes in the IDF (defining Messages, etc.) returned to their original state with wordwrap
– Having the comfort of the right mouse key back when defining the Model in IDF

After patching to the new release 9.7.02_G201 today, we noticed that the Scrollbar in the IDF Component Editor IS GONE! The mouse wheel for scrolling doesn’t work either! Confused

We have to withdraw this patch now from our development and productive environments again and revert to MG01 (9.7.02) from May.

Is it just my team? Is anyone else affected by this?

Regards,
Daniel

23 Jun 2016
10:28 am
Avatar
gianni
Member
Forum Posts: 237
Member Since:
01 Oct 2012
sp_UserOfflineSmall Offline

Hi Daniel,

I did a quick check on my W10 installation with G201 installed:
– mouse wheel is regularly working…
– scrollbars in component editor: I feel all usual scroll bars are in place…which is the one not showing in your case?

In my case W10 is a virtual vmware guest.

Regards,
Gianni

23 Jun 2016
1:41 pm
Avatar
Daniel_Kurz
Member
Forum Posts: 16
Member Since:
26 Jul 2013
sp_UserOfflineSmall Offline

Hi Gianni,

thanks for your reply. The only scrollbar which is missing is the one right in the middle-window called PROC-Editor. In the other Boxes (Tree, Entries, Triggers) the scrollbar works perfectly fine. Tested it on Win7 and Win10

Regards,
Daniel

23 Jun 2016
8:15 pm
Avatar
gianni
Member
Forum Posts: 237
Member Since:
01 Oct 2012
sp_UserOfflineSmall Offline

I do not see them either…I feel scrollbars in that frame were vanished in U9.7.01.G104 also…
For your info I am following a Uniface potential issue with scrollbars moving from 9.6 to 9.7.01 still under investigation; this call was opened from an italian customer.

Hope it helps.

Regards,
Gianni

24 Jun 2016
9:44 am
Avatar
Daniel_Kurz
Member
Forum Posts: 16
Member Since:
26 Jul 2013
sp_UserOfflineSmall Offline

In fact its good news that we are not the only ones affected by this issue. That helps creating a case.

From my perspective G201 is therefore useless since an essential part of the IDF is broken.

Regards,
Daniel

24 Jun 2016
10:49 am
Avatar
diseli
Admin
Forum Posts: 786
Member Since:
01 Oct 2012
sp_UserOfflineSmall Offline

I can confirm the problem (it seems to be a side-effect of the bug fix 31171) and I’ve created a new bug report for this (31257).

Luckily there’s an easy workaround: in case you specifically enable the vertical and horizontal scroll bars for the RichEdit widget (this is used by the ProcBox in the Component Editor) then all is back to “normal”. This can be done by changing the widget definitions for the RichEdit widget in the INI file to:

RichEdit=urichedit(font=monomedium;procbox=on;dynamic=on;hscroll=on;vscroll=on)

Please note that I’ve also enabled the dynamic property so that the scroll bars are only displayed when necessary.

Hope this helps.

Kind regards,
Daniel
Uniface Support

24 Jun 2016
11:17 am
Avatar
Lauterbach
Member
Forum Posts: 25
Member Since:
06 Dec 2012
sp_UserOfflineSmall Offline

I see all the scrollbars on WIN 7.

I installed a fresh new Version from /downloads/Uniface/distributions/9702/Windows/W32

 

Regards

Norbert

24 Jun 2016
11:49 am
Avatar
Daniel_Kurz
Member
Forum Posts: 16
Member Since:
26 Jul 2013
sp_UserOfflineSmall Offline

 @Daniel: Thanks for the workaround, it works.

@Lauterbach: Its not about 9.7.02, its about the first patch named 9.7.02 G201 released in June.

Regards,
Daniel

24 Jun 2016
5:16 pm
Avatar
diseli
Admin
Forum Posts: 786
Member Since:
01 Oct 2012
sp_UserOfflineSmall Offline

diseli said
This can be done by changing the widget definitions for the RichEdit widget in the INI file to:

RichEdit=urichedit(font=monomedium;procbox=on;dynamic=on;hscroll=on;vscroll=on)

Small correction: these are the default settings for the RichEdit widget in Uniface 9.7.xx:

RichEdit=urichedit(font=procboxfont;maxtags=20;procbox=on)

And the workaround is to add the following settings: “dynamic=on;hscroll=on;vscroll=on”; e.g.

RichEdit=urichedit(font=procboxfont;maxtags=20;procbox=on;dynamic=on;hscroll=on;vscroll=on)

Please note that the HtmlEdit widget is also affected by this problem. It is used when the Source Editor is enabled as the internal layout storage (instead of the Graphical Editor) in the Server Page Properties. Here are the updated widget definitions:

HtmlEdit=urichedit(font=procboxfont;procbox=on;language=html;dynamic=on;hscroll=on;vscroll=on)

Hope this helps.

Regards,

Daniel
Uniface Support

UPDATE[June 24, 2016 @ 17:16]: it is actually not necessary to enable the dynamic properties; the mentioned workaround will also will work without it

Forum Timezone: Europe/Amsterdam

Most Users Ever Online: 131

Currently Online:
21 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

ulrich-merkel: 1677

Iain Sharp: 596

Theo Neeskens: 333

gianni: 237

rogerw: 228

lalitpct: 195

istiller: 191

-GHAN-: 171

Knut: 168

sochaz: 165

Member Stats:

Guest Posters: 3

Members: 4727

Moderators: 0

Admins: 8

Forum Stats:

Groups: 1

Forums: 62

Topics: 1980

Posts: 8555

Newest Members:

RonnieArror, MashaEcs, CeccilCet, etcuvuqe, TotaluTwino, ueemporuveson, Kvas, Ernestastor, Roxbo, Aliafah

Administrators: admin: 23, Adrian Gosbell: 268, diseli: 786, Bob Maier: 2, Nico Peereboom: 58, Michael Rabone: 4, richiet: 406, JanCees: 25